A targeted temporary fix has been applied to affected customers and appears to be effective. We continue to monitor the situation.
The issue is caused by a bug in Cloudflare services that causes HEAD requests to be mishandled and returned as code 520. The bug occurs on a small proportion of requests. We are in contact with Cloudflare to confirm the nature of the issue and find a more permanent fix.
Posted Mar 17, 2026 - 19:08 UTC
Investigating
We have tracked the issue down to a likely bug in our upstream provider (Cloudflare) and are investigating possible solutions.
For the moment, users can work around by issuing GET requests for the same resources and just discarding the body. GET requests appear not affected by the issue.
Posted Mar 17, 2026 - 06:34 UTC
This incident affects: DreamApply Platform Services (DreamApply API).